Aquesta entrada es un apunt ràpid per a mi, però si li serveix a algú perfecte.
A debian, després d'una actualització em va deixar de funcionar el bumblebee (primusrun)
Fent proves, al executar
primusrun -vvvvv glxgears
Es quedava la consola enganxada, però no mostrava res.
Aleshores mirant la traça /var/log/Xorg.8.log mostrava l'error:
/dev/dri/card0: failed to set DRM interface version 1.4: Permission denied

Vaig estar cercant per un munt de fòrums i provant un munt de coses, i al final va resultar que la última versió del driver d'nvidia no funciona bé amb el bumblebee. Vaig instalar la versió 340 amb l'apt
apt install nvidia-legacy-340xx-driver
i aleshores configurar el bumblebee per a que fes servir aquesta versió amb
sudo update-glx --config nvidia

i això es tot

Previous Post Next Post

Add a comment